Uprint Down

Minor incident Print & Copy Services
21-09-22 10:59 GMT · 1 hour, 35 minutes

Updates

Resolved

Resolved by Cantec

September 21, 2022 · 12:35 GMT
Issue

Students can submit print jobs from their device but these print jobs do not appear in their queue at the printer.

September 21, 2022 · 11:00 GMT

← Back