Uprint Down

Minor incident Print & Copy Services
22-09-22 13:36 IST · 30 minutes

Updates

Resolved

resolved by cantec

September 22, 2022 · 14:06 IST
Issue

Students can submit print jobs but these jobs do not appear in their queue at the printer.

September 22, 2022 · 13:36 IST

← Back