Uprint Down

Minor incident Print & Copy Services
22-09-22 16:16 IST · 25 minutes

Updates

Resolved

resolved by cantec

September 22, 2022 · 16:41 IST
Issue

Students can submit jobs but these jobs are not appearing in the student’s queue at the printer

September 22, 2022 · 16:16 IST

← Back