Uprint Down

Minor incident Print & Copy Services
26-09-22 13:20 IST · 34 minutes

Updates

Resolved

Resolved by Cantec

September 26, 2022 · 13:54 IST
Issue

Students can upload jobs to their print queue but these jobs do not appear in the student’s queue at the printer

September 26, 2022 · 13:21 IST

← Back