Uprint Down

Minor incident Print & Copy Services
27-09-22 12:41 IST · 32 minutes

Updates

Resolved

Resolved by Cantec

September 27, 2022 · 13:14 IST
Issue

Students can upload print jobs to their print queue but these jobs not appearing at the printers.

September 27, 2022 · 12:41 IST

← Back