Uprint Down

Minor incident Print & Copy Services
30-09-22 14:00 IST · 2 hours, 6 minutes

Updates

Resolved

Resolved by Cantec

September 30, 2022 · 16:06 IST
Issue

Students can upload jobs to their print queue but these jobs not appearing in their queue at the printer

September 30, 2022 · 16:06 IST

← Back