Uprint Down

Minor incident Print & Copy Services
04-10-22 14:20 IST · 2 hours, 4 minutes

Updates

Resolved

Resolved by Cantec

October 4, 2022 · 16:24 IST
Investigating

Resolved by Cantec

October 4, 2022 · 16:24 IST
Issue

Students can upload jobs to their print queue but these calls are not appearing in the student’s queue at the printers

October 4, 2022 · 14:20 IST

← Back