Uprint Down

Minor incident Print & Copy Services
06-10-22 14:39 IST · 37 minutes

Updates

Resolved

Resolved by Cantec

October 6, 2022 · 15:17 IST
Issue

Students can upload jobs to Uprint but these jobs are not showing in student’s print queues at the printers.

October 6, 2022 · 14:40 IST

← Back