Uprint Down

Major incident Print & Copy Services
2022-10-06 16:56 GMT · 15 hours, 10 minutes

Updates

Resolved

Uprint has been taken down for maintenance

October 7, 2022 · 08:07 GMT
Investigating

Jobs are not appearing in print queue list when students send their jobs, even thought they get a successfully submitted message.

October 6, 2022 · 16:57 GMT

← Back