Uprint Upgrade from 07-10-22 08:07 GMT to 10-10-22 11:43 GMT

Scheduled maintenance Print & Copy Services
2022-10-07 08:07 GMT · 3 days, 3 hours, 35 minutes

Updates

Resolved

Maintenance finished - Uprint sytem upgraded

October 10, 2022 · 11:43 GMT
Monitoring

Scheduled maintenance complete

October 7, 2022 · 14:07 GMT
Scheduled

Uprint down for maintenance and upgrade

October 7, 2022 · 08:07 GMT

← Back