Uprint Down

Minor incident Print & Copy Services
13-10-22 09:10 IST · 2 hours, 6 minutes

Updates

Resolved

Issue resolved

October 13, 2022 · 11:16 IST
Issue

Student can upload jobs to their queue from their devices but these print jobs are not appearing in the students queue at the printers

October 13, 2022 · 09:11 IST

← Back