Citrix - Unable to connect

Major incident VirtualApp (Citrix)
12-12-22 09:09 GMT · 25 minutes

Updates

Resolved

Issue is now resolved and users are able to connect again as normal

December 12, 2022 · 09:46 GMT
Update

Current Status: Citrix Engineering has applied a mitigation to the issue and is currently monitoring the recovery of the service.

December 12, 2022 · 09:32 GMT
Issue

Users may be unable to connect to Citrix.
Citrix have identified the issue and are working on a solution.
Further Update at 9.30
Further info here https://status.cloud.com/incidents/431681

December 12, 2022 · 09:13 GMT

← Back