Citrix DaaS service may be experiencing issues in the EU

Minor incident VirtualApp (Citrix)
18-01-23 09:34 GMT · 1 hour, 26 minutes

Updates

Resolved

Issue resolved by Citrix

January 18, 2023 · 11:00 GMT
Issue

Citrix DaaS service may be experiencing issues in the EU.
Currently we haven’t had any reports from our own users.

January 18, 2023 · 09:42 GMT

← Back