MyStudentAdmin Down

Minor incident My Student Admin
28-02-23 10:17 IST · 33 minutes

Updates

Resolved

Students access to MyStudentAdmin has been restored

February 28, 2023 · 10:51 IST
Issue

Students to not have access to MyStudentAdmin - receiving ‘Forbidden’ 403 error message

February 28, 2023 · 10:19 IST

← Back