Printing Unavailable for Staff and Students

Minor incident Print & Copy Services
29-03-23 09:44 IST · 5 hours, 36 minutes

Updates

Resolved

Issue has been resolved by Cantec

March 29, 2023 · 15:20 IST
Issue

Students and staff are unable to sign into printers. Printers continuously displaying the ‘Trying to login’ screen but login does not pass this.

Cantec have been notified

March 29, 2023 · 13:19 IST

← Back