Uprint unavailable

Minor incident Print & Copy Services
24-04-23 09:44 IST · 4 hours, 30 minutes

Updates

Resolved

Uprint is available again, the license issue was resolved.

April 24, 2023 · 14:14 IST
Issue

Uprint is unavailable. Students are receiving a license error. Cantec have been advised.

April 24, 2023 · 09:44 IST

← Back