MyStudentAdmin - Down

Minor incident My Student Admin
04-07-23 10:00 IST · 2 hours, 40 minutes

Updates

Resolved

Issue resolved

July 4, 2023 · 12:40 IST
Issue

Students are currently unable to access their MyStudentAdmin. When attempting to access this service, students will receive the ‘Forbidden’ 404 error message.

July 4, 2023 · 10:00 IST

← Back