Students Printing - Down

Minor incident Print & Copy Services
04-10-23 15:15 IST · 50 minutes

Updates

Resolved

Issue resolved

October 4, 2023 · 16:05 IST
Issue

Students unable to log into printers. Receive ‘trying to log in, please wait’ message but does not progress beyond this.

Issue raised with Cantec.

October 4, 2023 · 15:15 IST

← Back