University College Cork - System Status
Subscribe
to updates
Uprint Unavailable
Minor incident
Print & Copy Services
17-10-23 09:26 IST
· 52 minutes
Updates
Resolved
Uprint is now available again.
October 17, 2023 · 10:18 IST
Issue
Submitted print jobs expire. Cantec are investigating.
October 17, 2023 · 09:26 IST
← Back