Uprint Down

Minor incident Print & Copy Services
24-10-23 13:00 IST · 1 hour, 44 minutes

Updates

Resolved

Resolved by Cantec

October 24, 2023 · 14:44 IST
Issue

Students cannot print. Students can submit print jobs but these jobs are not being processed correctly.

Print jobs remain in ‘awaiting processing’ and are not marked as available for release.

Cantec investigating

October 24, 2023 · 13:00 IST

← Back