Uprint Down

Minor incident Print & Copy Services
25-03-24 09:12 IST · 39 minutes

Updates

Resolved

Issue resolved by Cantec

March 25, 2024 · 09:51 IST
Issue

Students are unable to load the Uprint login page.

Students receive the error below:
uprint.ucc.ie took too long to respond

Cantec notified

March 25, 2024 · 09:12 IST

← Back