MyStudentAdmin - Down

Major incident My Student Admin
02-04-24 09:28 IST · 27 minutes

Updates

Resolved

Issue resolved

April 2, 2024 · 09:56 IST
Issue

Students are currently unable to access MyStudentAdmin.

Students are presented with a blank webpage after completing the O365 login for this service.

April 2, 2024 · 09:28 IST

← Back