Printing Service Temporarily Unavailable
Major incident
Print & Copy Services
07-05-24 10:30 IST
· 3 days, 5 hours, 17 minutes
Updates
Resolved
May 10, 2024 · 15:46 IST
Issue was resolved on Thursday morning @9am. Incident impacted uprint.ucc.ie only. Apologies for any inconvience.
Issue
May 8, 2024 · 08:42 IST
We are currently experiencing issues with printing/uprint. The exams office have been notified and students presenting at exams should advise the invigilator that the printing service was unavailable.
← Back