Network

Major incident Campus Network
17-02-25 09:34 GMT · 1 hour, 44 minutes

Updates

Resolved

Resolved. Services back to normal.

February 17, 2025 · 11:18 GMT
Issue

Loss of Connectivity in the North Campus. LAN and Wi-Fi not working

Currently investigating and working to resolve.

February 17, 2025 · 09:34 GMT

← Back