MyStudentAdmin

Major incident My Student Admin
24-02-25 16:59 GMT · 15 hours, 9 minutes

Updates

Resolved

MyStudentAdmin is available.

February 25, 2025 · 08:08 GMT
Issue

Students are receiving the error message SAML Ascertion validation Failed when trying to access MyStudentAdmin.

February 24, 2025 · 16:59 GMT

← Back