Intermittent problems with the UCC connection to the internet (MS Teams & Citrix (VirtualApp) affected)

Minor incident Microsoft 365 VirtualApp (Citrix) Campus Network
09-04-25 15:29 IST · 1 day, 22 hours, 43 minutes

Updates

Resolved

Issue is now resolved

April 11, 2025 · 12:07 IST
Issue

Please be advised that we are experiencing intermittent problems with the UCC connection to the internet. This is impacting some users and causing Citrix (VirtualApp) sessions to be dropped and users dropped from Teams calls. The root cause of the issue is under investigation

Main services affected are: MS Teams and Citrix (VirtualApp).

April 9, 2025 · 15:29 IST

← Back