Loss of Network Connectivity - North Campus

Minor incident Campus Network
03-07-25 09:22 IST · 3 hours, 15 minutes

Updates

Resolved

Incident Resolved

July 3, 2025 · 12:37 IST
Issue

Loss of connectivity in Enterprise Centre, Butler Building, Cooperage, Distillery House and St Vincents.

We are working to resolve

July 3, 2025 · 09:22 IST

← Back