T4 offiline

Minor incident TerminalFour CMS
15-09-25 09:11 IST · 32 minutes

Updates

Resolved

T4 CMS is available once more at https://bali.ucc.ie/terminalfour/

September 15, 2025 · 09:43 IST
Issue

T4 is currently offline. The issue is being investigated.

September 15, 2025 · 09:11 IST

← Back