Eduroam connection issue

Minor incident Eduroam
08-10-25 11:58 IST · 23 hours, 6 minutes

Updates

Resolved

Issue has been resolved.

October 9, 2025 · 11:04 IST
Issue

There are reports of intermittent wi-fi connectivity issues. We are currently investigating.

October 8, 2025 · 11:58 IST

← Back