Agresso is currently unavailable
Major incident
Agresso
29-10-25 16:53 GMT
· 15 hours, 21 minutes
Updates
Resolved
October 30, 2025 · 08:07 GMT
Resolution: A global issue with MS Azure impacted SSO for Agresso. This is now resolved.
Issue
October 29, 2025 · 16:53 GMT
Agresso is currently unavailable. We are investigating the issue and will provide an update shortly.
← Back
University College Cork - System Status