My Student Admin - SAML Errors
Major incident
My Student Admin
11-11-25 16:30 GMT
· 28 minutes
Updates
Resolved
November 11, 2025 · 16:57 GMT
This issue has now been resolved. We apologise for any inconvenience this may have cause today.
Issue
November 11, 2025 · 16:49 GMT
This is currently under investigation by IT Services - we apologise for any inconvenience this may cause
← Back
University College Cork - System Status