Agresso Sign On

Major incident Agresso
18-12-25 09:28 GMT · 51 minutes

Updates

Resolved

This issue has now been resolved - we apologise for any inconvenience caused.

December 18, 2025 · 10:18 GMT
Issue

Issues with Accessing the Agresso System - SSO affected - issue with Vendor Unit 4 - being investigated

December 18, 2025 · 09:28 GMT

← Back