Security incident involving Canvas

Major incident Canvas
05-05-26 11:18 IST · 3 days, 18 hours, 48 minutes

Updates

Monitoring

We continue to monitor the situation closely and will provide further updates as more information becomes available.

Canvas remains fully operational. If you have any queries, please log a case at https://portal.ucc.ie

May 6, 2026 · 15:17 IST
Monitoring

IT Services is aware of a security incident involving Canvas, the university’s virtual learning environment. We are actively monitoring updates from the platform provider, Instructure and assessing any impact to university services. This is a global event affecting multiple institutions.
At present, UCC has not been notified of any direct impact to our university or data.

Canvas remains available and operational. No impact to other UCC systems has been identified and staff and students should continue to use Canvas as normal.

We will continue to monitor the situation and will provide updates as new information emerges. In the meantime, the incident is being managed via https://status.ucc.ie

May 5, 2026 · 11:18 IST

← Back