Print Outage

Major incident Print & Copy Services
17-11-21 15:05 IST · 37 minutes

Updates

Resolved

Student printers in the Boole Library are back online. We are investigating the cause.

November 17, 2021 · 15:42 IST
Investigating

The student printers in the Boole Library are currently offline. The error message displayed is “trying to log in, please wait a moment” We are currently investigating the issue.

November 17, 2021 · 15:07 IST

← Back