Library.ucc.ie is unavailable due to essential IT security maintenance

Major incident Library
12-12-21 19:30 IST · 1 day, 20 hours, 14 minutes

Updates

Resolved

Library.ucc.ie is now available

December 14, 2021 · 15:44 IST
Update

Library.ucc.ie remains under maintenance and we are working to have it back online later this week.

December 13, 2021 · 15:51 IST
Issue

• Access to the Library Catalogue, Book Holds and My Library Account is unavailable at this time. 
• Access to online journals, ebooks and library databases all remain available via the library website: https://libguides.ucc.ie/library
• Students may also search for items from physical library collections by searching OneSearch:  https://ucc.summon.serialssolutions.com/.
• Exam Papers remain accessible at https://libguides.ucc.ie/examinationpapers.

December 12, 2021 · 19:58 IST

← Back