MyStudentAdmin is unavailable due to essential IT security maintenance

Major incident My Student Admin
12-12-21 19:58 IST · 1 day, 15 hours, 46 minutes

Updates

Resolved

Mystudentadmin.ucc.ie is back online

December 14, 2021 · 11:44 IST
Update

Mystudentadmin.ucc.ie will be back online tomorrow, Tuesday 14th December at 11am.

December 13, 2021 · 15:50 IST
Issue

While this website is offline, the Semester 1 Examination Timetables are available on https://mystudentadmin.ucc.ie/Exam-Timetable.pdf

December 12, 2021 · 20:04 IST

← Back