Uprint

Minor incident Print & Copy Services
01-02-22 14:39 IST · 59 minutes

Updates

Resolved

Cantec cleared out the queue and re-started the services.

February 1, 2022 · 15:38 IST
Investigating

Uprint issue. Documents are being submitted but are not printing.

February 1, 2022 · 14:40 IST

← Back