Uprint is currently unavailable

Minor incident Print & Copy Services
2022-03-07 14:19 IST · 59 minutes, 51 seconds

Updates

Resolved

UPrint is back up and running. Cantec cleared a print job that was holding up the queue.

March 7, 2022 · 15:19 IST
Issue

Print jobs are not uploading. Cantec are investigating the issue.

March 7, 2022 · 14:20 IST

← Back