Uprint

Minor incident Print & Copy Services
2022-03-11 13:05 IST · 1 hour, 23 minutes, 49 seconds

Updates

Resolved

The Uprint issue has been resolved by Cantec.

March 11, 2022 · 14:29 IST
Issue

Uprint is currently down, students can submit jobs but cannot print them. Cantec are investigating.

March 11, 2022 · 13:06 IST

← Back