Agresso is unavailable

Major incident Agresso
2022-03-24 18:37 IST · 13 hours, 52 minutes, 22 seconds

Updates

Resolved

Agresso is now available

March 25, 2022 · 08:29 IST
Issue

Due to ongoing datacentre issues, Agresso is unavailable

March 24, 2022 · 18:47 IST

← Back