Uprint

Minor incident Print & Copy Services
2022-04-04 11:15 IST · 3 hours, 10 minutes, 57 seconds

Updates

Resolved

Cantec restarted the Uprint queue.

April 4, 2022 · 14:26 IST
Issue

Students can upload documents but the documents are not appearing on the printers. Cantec have been advised.

April 4, 2022 · 11:17 IST

← Back