Uprint

Minor incident Print & Copy Services
2022-04-06 11:41 IST · 3 hours, 7 minutes, 27 seconds

Updates

Resolved

Cantec resolved the issue.

April 6, 2022 · 14:49 IST
Issue

Uprint is currently not working. Print jobs are being submitted but not printing.

April 6, 2022 · 11:43 IST

← Back