Uprint

Minor incident Print & Copy Services
2022-07-28 09:53 IST · 1 hour, 6 minutes

Updates

Resolved

Uprint is working, the uniflow service was restarted.

July 28, 2022 · 11:00 IST
Issue

Uprint is currently unavailable. Student can submit print jobs but not print.

July 28, 2022 · 09:55 IST

← Back