Uprint

Minor incident Print & Copy Services
04-08-22 11:25 IST · 28 minutes

Updates

Resolved

Uprint is available again.

August 4, 2022 · 11:53 IST
Issue

Uprint is currently unavailable. Students can submit jobs but they are not appearing on the printers.

August 4, 2022 · 11:25 IST

← Back