Uprint Down

Minor incident Print & Copy Services
26-08-22 14:29 IST · 1 hour, 24 minutes

Updates

Resolved

Resolved by Cantec

August 26, 2022 · 15:53 IST
Issue

Students can submit jobs but these print jobs are not appearing in the print queue

August 26, 2022 · 14:31 IST

← Back