Uprint Down

Minor incident Print & Copy Services
30-08-22 14:33 GMT · 46 minutes

Updates

Resolved

Resolved by Cantec

August 30, 2022 · 15:20 GMT
Issue

Students can upload print jobs from their device but no print jobs are appearing in their print queue on the printer

August 30, 2022 · 14:38 GMT

← Back