Uprint Down

Minor incident Print & Copy Services
05-09-22 14:11 GMT · 2 hours, 24 minutes

Updates

Resolved

Issue resolved by Cantec

September 5, 2022 · 16:35 GMT
Issue

Student can upload print jobs from their devices but these jobs are not showing in the queue on printers.

September 5, 2022 · 14:12 GMT

← Back