Uprint Down

Minor incident Print & Copy Services
12-09-22 15:58 IST · 27 minutes

Updates

Resolved

Issue resolved by Cantec

September 12, 2022 · 16:25 IST
Issue

Students can upload print jobs to their queue but these print jobs are not appearing in their queue at the printer.

September 12, 2022 · 15:59 IST

← Back