Uprint Down

Minor incident Print & Copy Services
13-09-22 11:41 IST · 2 hours, 58 minutes

Updates

Resolved

Resolved by Cantec

September 13, 2022 · 14:40 IST
Issue

Students can upload print jobs to their queue but these jobs do not appear at the printer.

September 13, 2022 · 11:41 IST

← Back