Uprint Down

Minor incident Print & Copy Services
2022-09-14 10:18 GMT · 4 hours, 56 minutes

Updates

Resolved

Resolved by Cantec

September 14, 2022 · 15:14 GMT
Issue

Students can successfully upload jobs to their print queue but these jobs do not appear in their queue at the printer.

September 14, 2022 · 10:18 GMT

← Back